re = /^(?=[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.{2,8}$)(.*)/m
str = 'Pass:
Aa1
Bbcdd123
Cc3
Fail:
abc
Bbbccdd123Bbbccdd123
123
aB2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end