import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]+(?:[[:punct:]][A-Z]+)*(?=\\s+application)";
final String string = "Conversion routine for the NYC.GENX application. - should show 'NYC.GENX'\n"
+ "Conversion routine for the CAP-GENY application. - should show 'CAP-GENY'\n"
+ "Conversion routine for the NNUAT_CHECK application. - should show 'NNUAT_CHECK'\n"
+ "Created on 1/1/14 11:40 AM for RUN_SCRIPT application. - should show 'NNUAT_CHECK'\n"
+ "Event created on 2/2/14 12:29 PM for the STOP_SERVER application. - should show 'STOP_SERVER'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}