const regex = /\\U.+?(\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\U.+?(\\s)', 'gm')
const str = `VITAMIN \\U0026 SUPPLEMENTS STORE`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);