$re = '/\\\\U.+?(\s)/m';
$str = 'VITAMIN \\U0026 SUPPLEMENTS STORE';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;