use strict;
my $str = 'VITAMIN \\U0026 SUPPLEMENTS STORE';
my $regex = qr/\\U.+?(\s)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";