#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)(\w)\*(.*)"
Local $sString = "This is ju* an example" & @CRLF & _
"This is * an example" & @CRLF & _
"T* is just an example" & @CRLF & _
"* is just an example" & @CRLF & _
"This is just an ex*" & @CRLF & _
"This is just an *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")