package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(\w)\*(.*)`)
var str = `This is ju* an example
This is * an example
T* is just an example
* is just an example
This is just an ex*
This is just an *`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}