const regex = /<rupture dip="(\d+\.\d+)" id="[^"]*" magnitude="(\d+\.\d+)" rake="(\d+\.\d+)" strike="(\d+\.\d+)" tectonicRegion="[^"]*">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<rupture dip="(\\d+\\.\\d+)" id="[^"]*" magnitude="(\\d+\\.\\d+)" rake="(\\d+\\.\\d+)" strike="(\\d+\\.\\d+)" tectonicRegion="[^"]*">', 'g')
const str = `<rupture dip="30.0" id="trt=00~ses=0173~src=1~rup=2-01" magnitude="5.25" rake="60.0" strike="322.0" tectonicRegion="Active Shallow Crust">
<rupture dip="60.0" id="trt=00~ses=0532~src=1~rup=1-01" magnitude="4.75" rake="60.0" strike="322.0" tectonicRegion="Active Shallow Crust">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}