// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<rupture dip="(\d+\.\d+)" id="[^"]*" magnitude="(\d+\.\d+)" rake="(\d+\.\d+)" strike="(\d+\.\d+)" tectonicRegion="[^"]*">"#).unwrap();
let string = "<rupture dip=\"30.0\" id=\"trt=00~ses=0173~src=1~rup=2-01\" magnitude=\"5.25\" rake=\"60.0\" strike=\"322.0\" tectonicRegion=\"Active Shallow Crust\">
<rupture dip=\"60.0\" id=\"trt=00~ses=0532~src=1~rup=1-01\" magnitude=\"4.75\" rake=\"60.0\" strike=\"322.0\" tectonicRegion=\"Active Shallow Crust\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}