$re = '/<rupture dip="(\d+\.\d+)" id="[^"]*" magnitude="(\d+\.\d+)" rake="(\d+\.\d+)" strike="(\d+\.\d+)" tectonicRegion="[^"]*">/';
$str = '<rupture dip="30.0" id="trt=00~ses=0173~src=1~rup=2-01" magnitude="5.25" rake="60.0" strike="322.0" tectonicRegion="Active Shallow Crust">
<rupture dip="60.0" id="trt=00~ses=0532~src=1~rup=1-01" magnitude="4.75" rake="60.0" strike="322.0" tectonicRegion="Active Shallow Crust">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);