import re
regex = re.compile(r"<rupture dip=\"(\d+\.\d+)\" id=\"[^\"]*\" magnitude=\"(\d+\.\d+)\" rake=\"(\d+\.\d+)\" strike=\"(\d+\.\d+)\" tectonicRegion=\"[^\"]*\">")
test_str = ("<rupture dip=\"30.0\" id=\"trt=00~ses=0173~src=1~rup=2-01\" magnitude=\"5.25\" rake=\"60.0\" strike=\"322.0\" tectonicRegion=\"Active Shallow Crust\">\n"
"<rupture dip=\"60.0\" id=\"trt=00~ses=0532~src=1~rup=1-01\" magnitude=\"4.75\" rake=\"60.0\" strike=\"322.0\" tectonicRegion=\"Active Shallow Crust\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")