import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.+?(?=(__|_FF|_SS|_TT|_FS|_SF)))";
final String string = "CALOUT_DFE_0__FFGNP_0P9VDD_0P72VDDA_0C_Cbest\n"
+ "rxdetout_SSGNP_1P05VDD_0P88VDDA_M40C_Cworst";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}