use strict;
my $str = 'CALOUT_DFE_0__FFGNP_0P9VDD_0P72VDDA_0C_Cbest
rxdetout_SSGNP_1P05VDD_0P88VDDA_M40C_Cworst';
my $regex = qr/(^.+?(?=(__|_FF|_SS|_TT|_FS|_SF)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}