re = /(^.+?(?=(__|_FF|_SS|_TT|_FS|_SF)))/m
str = 'CALOUT_DFE_0__FFGNP_0P9VDD_0P72VDDA_0C_Cbest
rxdetout_SSGNP_1P05VDD_0P88VDDA_M40C_Cworst'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end