using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\d{8}|[a-f]{8})[a-f\d]{8}";
string input = @"online-release-0202-c3764ab8-02022329
online-release-0202-02022329-c3764ab8
online-release-0202-02022329-ffffffff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}