$re = '/(?!\d{8}|[a-f]{8})[a-f\d]{8}/m';
$str = 'online-release-0202-c3764ab8-02022329
online-release-0202-02022329-c3764ab8
online-release-0202-02022329-ffffffff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);