using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\[.*\].*\[client\s+.*:.*\].*authentication\s+failure.*\.php$";
string input = @"[:error] [pid 30993] [client 185.58.152.203:34368] user truj6j authentication failure, referer: https://able.su/index.php/author-login";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}