import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\[.*\\].*\\[client\\s+.*:.*\\].*authentication\\s+failure.*\\.php$";
final String string = "[:error] [pid 30993] [client 185.58.152.203:34368] user truj6j authentication failure, referer: https://able.su/index.php/author-login";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}