import re
regex = re.compile(r"^.*\[.*\].*\[client\s+.*:.*\].*authentication\s+failure.*\.php$")
test_str = "[:error] [pid 30993] [client 185.58.152.203:34368] user truj6j authentication failure, referer: https://able.su/index.php/author-login"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")