const regex = new RegExp('^.*\\[.*\\].*\\[client\\s+.*:.*\\].*authentication\\s+failure.*\\.php$', 'g')
const str = `[:error] [pid 30993] [client 185.58.152.203:34368] user truj6j authentication failure, referer: https://able.su/index.php/author-login`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}