# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\P{Hebrew}//g;t' <<< "h1: הללו את יהוה כל גוים שבחוהו כל האמים
r1: Praise the LORD, all nations! Extol him, all peoples!
g1: Αλληλουια. Αἰνεῖτε τὸν κύριον, πάντα τὰ ἔθνη, ἐπαινέσατε αὐτόν, πάντες οἱ λαοί,
b1: Alleluia. Praise the Lord all you nations: praise him all you peoples."