using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\P{Hebrew}";
string substitution = @"";
string input = @"h1: הללו את יהוה כל גוים שבחוהו כל האמים
r1: Praise the LORD, all nations! Extol him, all peoples!
g1: Αλληλουια. Αἰνεῖτε τὸν κύριον, πάντα τὰ ἔθνη, ἐπαινέσατε αὐτόν, πάντες οἱ λαοί,
b1: Alleluia. Praise the Lord all you nations: praise him all you peoples.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}