$re = '/class="Tytul">(.*?)<\/span>/';
$str = 'class="Tytul"><span itemprop="name">Zły ekspres</span></span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);