re = /class="Tytul">(.*?)<\/span>/
str = 'class="Tytul"><span itemprop="name">Zły ekspres</span></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end