import re
regex = re.compile(r"<(.+?)class=\s*\"([^\"]*?)\"", flags=re.MULTILINE)
test_str = "<h1 class=\"big blue\" id=\"testing\"> some text </h1><div id=\"foo\" class=\"blue danube page-title\"> some text </div><span class=\"\"></span>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")