// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<(.+?)class=\s*"([^"]*?)""#).unwrap();
let string = "<h1 class=\"big blue\" id=\"testing\"> some text </h1><div id=\"foo\" class=\"blue danube page-title\"> some text </div><span class=\"\"></span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}