#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:#\w+(?:-\w+)?)+(?::{[\w-]+})?"
Local $sString = "jlkjlkjlkjlkj" & @CRLF & _
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343:{asdf9230-232_jk233} lkjlj" & @CRLF & _
"slkjlj" & @CRLF & _
"Example 2:" & @CRLF & _
"" & @CRLF & _
"jlkjlkjlkjlkj" & @CRLF & _
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22:{asdf9230-232_jk233} #test12345-abc#slkjs3234-df#slkj23423#Other:{asdf9230-232_jk233} lkjlj" & @CRLF & _
"slkjlj" & @CRLF & _
"Example 3:" & @CRLF & _
"" & @CRLF & _
"jlkjlkjlkjlkj" & @CRLF & _
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343: lkjlj" & @CRLF & _
"slkjlj" & @CRLF & _
"Example 4:" & @CRLF & _
"" & @CRLF & _
"jlkjlkjlkjlkj" & @CRLF & _
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22: #test12345-abc#slkjs3234-df#slkj23423#Other: lkjlj" & @CRLF & _
"slkjlj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")