import re
regex = re.compile(r"(?:#\w+(?:-\w+)?)+(?::{[\w-]+})?", flags=re.MULTILINE)
test_str = ("jlkjlkjlkjlkj\n"
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343:{asdf9230-232_jk233} lkjlj\n"
"slkjlj\n"
"Example 2:\n\n"
"jlkjlkjlkjlkj\n"
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22:{asdf9230-232_jk233} #test12345-abc#slkjs3234-df#slkj23423#Other:{asdf9230-232_jk233} lkjlj\n"
"slkjlj\n"
"Example 3:\n\n"
"jlkjlkjlkjlkj\n"
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343: lkjlj\n"
"slkjlj\n"
"Example 4:\n\n"
"jlkjlkjlkjlkj\n"
"lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22: #test12345-abc#slkjs3234-df#slkj23423#Other: lkjlj\n"
"slkjlj")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")