import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:#\\w+(?:-\\w+)?)+(?::\\{[\\w-]+\\})?";
final String string = "jlkjlkjlkjlkj\n"
+ "lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343:{asdf9230-232_jk233} lkjlj\n"
+ "slkjlj\n"
+ "Example 2:\n\n"
+ "jlkjlkjlkjlkj\n"
+ "lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22:{asdf9230-232_jk233} #test12345-abc#slkjs3234-df#slkj23423#Other:{asdf9230-232_jk233} lkjlj\n"
+ "slkjlj\n"
+ "Example 3:\n\n"
+ "jlkjlkjlkjlkj\n"
+ "lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343: lkjlj\n"
+ "slkjlj\n"
+ "Example 4:\n\n"
+ "jlkjlkjlkjlkj\n"
+ "lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22: #test12345-abc#slkjs3234-df#slkj23423#Other: lkjlj\n"
+ "slkjlj";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}