const regex = /(?:#\w+(?:-\w+)?)+(?::{[\w-]+})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:#\\w+(?:-\\w+)?)+(?::{[\\w-]+})?', 'gm')
const str = `jlkjlkjlkjlkj
lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343:{asdf9230-232_jk233} lkjlj
slkjlj
Example 2:
jlkjlkjlkjlkj
lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22:{asdf9230-232_jk233} #test12345-abc#slkjs3234-df#slkj23423#Other:{asdf9230-232_jk233} lkjlj
slkjlj
Example 3:
jlkjlkjlkjlkj
lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#slkjdj2343: lkjlj
slkjlj
Example 4:
jlkjlkjlkjlkj
lkjlkjlj lkjlkj #test12345-abc#slkjs3234-df#slkj23423#l23lkj22: #test12345-abc#slkjs3234-df#slkj23423#Other: lkjlj
slkjlj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}