#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$"
Local $sString = "^[.[?[a-azAz0-9[([.[?[a-zA-Z0-9[+[-_a-zA-Z0-9[?)*$" & @CRLF & _
"" & @CRLF & _
"^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$" & @CRLF & _
"" & @CRLF & _
"Valid Key Names:" & @CRLF & _
".auth_token" & @CRLF & _
"Key.pem" & @CRLF & _
"config_file" & @CRLF & _
"" & @CRLF & _
"Invalid Key Names:" & @CRLF & _
"Token..properties" & @CRLF & _
"auth file.json" & @CRLF & _
"_password.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")