re = /^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$/m
str = '^[.[?[a-azAz0-9[([.[?[a-zA-Z0-9[+[-_a-zA-Z0-9[?)*$
^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$
Valid Key Names:
.auth_token
Key.pem
config_file
Invalid Key Names:
Token..properties
auth file.json
_password.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end