// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$").unwrap();
let string = "^[.[?[a-azAz0-9[([.[?[a-zA-Z0-9[+[-_a-zA-Z0-9[?)*$
^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$
Valid Key Names:
.auth_token
Key.pem
config_file
Invalid Key Names:
Token..properties
auth file.json
_password.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}