package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$`)
var str = `^[.[?[a-azAz0-9[([.[?[a-zA-Z0-9[+[-_a-zA-Z0-9[?)*$
^[.]?[a-zAZ0-9]([.]?[a-zA-Z0-9]+[-_a-zA-Z0-9]?)*$
Valid Key Names:
.auth_token
Key.pem
config_file
Invalid Key Names:
Token..properties
auth file.json
_password.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}