using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{37,})[a-z\d]+(?:[-._][a-z\d]+)*$";
string input = @"abcd-efgH
1
a
123
abc
abc-asd-123-asd_asd.asd
-
abc-_asd
abc.
abc.-asd
123123-123123-ads--asd
091-asdsad---";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}