import re
regex = re.compile(r"^(?!.{37,})[a-z\d]+(?:[-._][a-z\d]+)*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("abcd-efgH\n"
"1\n"
"a\n"
"123\n"
"abc\n"
"abc-asd-123-asd_asd.asd\n"
"-\n"
"abc-_asd\n"
"abc.\n"
"abc.-asd\n"
"123123-123123-ads--asd\n"
"091-asdsad---")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")