$re = '/^(?!.{37,})[a-z\d]+(?:[-._][a-z\d]+)*$/mi';
$str = 'abcd-efgH
1
a
123
abc
abc-asd-123-asd_asd.asd
-
abc-_asd
abc.
abc.-asd
123123-123123-ads--asd
091-asdsad---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);