import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{37,})[a-z\\d]+(?:[-._][a-z\\d]+)*$";
final String string = "abcd-efgH\n"
+ "1\n"
+ "a\n"
+ "123\n"
+ "abc\n"
+ "abc-asd-123-asd_asd.asd\n"
+ "-\n"
+ "abc-_asd\n"
+ "abc.\n"
+ "abc.-asd\n"
+ "123123-123123-ads--asd\n"
+ "091-asdsad---";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}