#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}\-?\d{4}))$"
Local $sString = "91234-1234" & @CRLF & _
"1291234-1234" & @CRLF & _
"12 91234-1234" & @CRLF & _
"12 912341234" & @CRLF & _
"(12) 91234-1234" & @CRLF & _
"(12) 912341234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")