$re = '/^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}\-?\d{4}))$/mu';
$str = '91234-1234
1291234-1234
12 91234-1234
12 912341234
(12) 91234-1234
(12) 912341234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);