package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}-?\d{4}))$`)
var str = `91234-1234
1291234-1234
12 91234-1234
12 912341234
(12) 91234-1234
(12) 912341234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}