re = /^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}-?\d{4}))$/m
str = '91234-1234
1291234-1234
12 91234-1234
12 912341234
(12) 91234-1234
(12) 912341234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end