const regex = /^(?:(?:\+|00)?(55)\s?)?(?:\(?(0?[0-9]{2})\)?\s?)??(?:((?:9\d|[2-9])\d{3}-?\d{4}))$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\+|00)?(55)\\s?)?(?:\\(?(0?[0-9]{2})\\)?\\s?)??(?:((?:9\\d|[2-9])\\d{3}-?\\d{4}))$', 'gmu')
const str = `91234-1234
1291234-1234
12 91234-1234
12 912341234
(12) 91234-1234
(12) 912341234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}