package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(.*)(<iframe(?:.*?)</iframe>)(.*)`)
var str = `This is the article title
<iframe width="853" height="480" src="https://www.youtube.com/embed/23r23ffwe" frameborder="0" allowfullscreen></iframe>
This is the article text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}