// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(.*)(<iframe(?:.*?)</iframe>)(.*)").unwrap();
let string = "This is the article title
<iframe width=\"853\" height=\"480\" src=\"https://www.youtube.com/embed/23r23ffwe\" frameborder=\"0\" allowfullscreen></iframe>
This is the article text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}