use strict;
my $str = 'This is the article title
<iframe width="853" height="480" src="https://www.youtube.com/embed/23r23ffwe" frameborder="0" allowfullscreen></iframe>
This is the article text';
my $regex = qr@(.*)(<iframe(?:.*?)</iframe>)(.*)@sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}