$re = '@(.*)(<iframe(?:.*?)</iframe>)(.*)@s';
$str = 'This is the article title
<iframe width="853" height="480" src="https://www.youtube.com/embed/23r23ffwe" frameborder="0" allowfullscreen></iframe>
This is the article text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);