import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\s*((?:\\((?:Case\\b)?|\\d+(?:/\\d+)?[A-Za-z]+\\b).*)";
final String string = "Truly Mix 2/12Pk Cans - 12Z\n"
+ "Bud 16Z - LOOSE - 16Z\n"
+ "Blue Moon (Case 12x - 22Z)\n"
+ "2 for the show (6/4PK - 16Z)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}