// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?)\s*((?:\((?:Case\b)?|\d+(?:/\d+)?[A-Za-z]+\b).*)").unwrap();
let string = "Truly Mix 2/12Pk Cans - 12Z
Bud 16Z - LOOSE - 16Z
Blue Moon (Case 12x - 22Z)
2 for the show (6/4PK - 16Z)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}