const regex = new RegExp('^(.*?)\\s*((?:\\((?:Case\\b)?|\\d+(?:/\\d+)?[A-Za-z]+\\b).*)', 'gm')
const str = `Truly Mix 2/12Pk Cans - 12Z
Bud 16Z - LOOSE - 16Z
Blue Moon (Case 12x - 22Z)
2 for the show (6/4PK - 16Z)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}